Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need Help Using New Vape?
Author Message
jburn Offline
Junior Member
**

Posts: 4
Likes Given: 0
Likes Received: 1 in 1 posts
Joined: Aug 2016
Reputation: 0
Post: #1
Need Help Using New Vape?
Hey there, I recently just bought an eGrip II vape and I put on the atomizer that's labeled "RBA M&L"and it was working for a while but for some reason it gets pretty hot at only 30W and sometimes even burns my tongue a little. Then I tried to use a different one that wasn't RBA but it said 30-70W 0.25 Ohms and it got extremely hot and was even smoking right away when I tried using it, i'm not sure what i'm doing wrong
17-08-2016 08:30 PM
Find all posts by this user Like Post Quote this message in a reply
Ripnhl2005 Offline
When is this being released?
*****
FreeCycle

Posts: 936
Likes Given: 558
Likes Received: 877 in 454 posts
Joined: Aug 2016
Reputation: 10
Post: #2
RE: Need Help Using New Vape?
Welcome...What wattage are you running at when you installed the .25 ohm coil?
17-08-2016 08:51 PM
Find all posts by this user Like Post Quote this message in a reply
jburn Offline
Junior Member
**

Posts: 4
Likes Given: 0
Likes Received: 1 in 1 posts
Joined: Aug 2016
Reputation: 0
Post: #3
RE: Need Help Using New Vape?
(17-08-2016 08:51 PM)Ripnhl2005 Wrote:  Welcome...What wattage are you running at when you installed the .25 ohm coil?
30W
18-08-2016 12:34 AM
Find all posts by this user Like Post Quote this message in a reply
Ripnhl2005 Offline
When is this being released?
*****
FreeCycle

Posts: 936
Likes Given: 558
Likes Received: 877 in 454 posts
Joined: Aug 2016
Reputation: 10
Post: #4
RE: Need Help Using New Vape?
I thought maybe it was too high and frying the coil but not at 30 watts.

Anyone?
18-08-2016 12:39 AM
Find all posts by this user Like Post Quote this message in a reply
Post Reply