Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mutant mech mod problems
Author Message
Rs1911 Offline
Junior Member
**

Posts: 1
Likes Given: 0
Likes Received: 0 in 0 posts
Joined: May 2016
Reputation: 0
Post: #1
Mutant mech mod problems
Id like to say thank you in advance for any help. It's greatly appreciated. I purchased a mutant mech mod yesterday. This is my first mech mod. I have done hours upon hours of study to ensure safe operation. Altho when I put my temple 30mm rda on the top cap and snug the pin, and bring the batt rattle pin all the way in. Install the batt. I cant bring the bottom cap flush without an auto fire. I tried to ask guys at vape shops and they say dont snug it flush. I dont like the idea of a free twisting bottom cap that may turn a hair and fire. I have set this mod aside and will not use it without knowing safe opperation. I just go back to my rx200 lol. Do I need to buy a defferent mech? I am an experanced machinist so its not a problem remaching or shortening the batt rattle pin? Please help would love to use this mod safely. Thanks in advance
22-05-2016 08:46 PM
Find all posts by this user Like Post Quote this message in a reply
Michael Offline
TVF Veteran
*****

Posts: 6,756
Likes Given: 17,354
Likes Received: 7,435 in 3,870 posts
Joined: Sep 2014
Reputation: 60
Post: #2
RE: Mutant mech mod problems
It sounds like you've got a problem in the firing button. I had a Panzer mech with the same problem, any time I screwed it all the way in it would autofire. For me, the problem turned out that I was missing an o-ring between the firing button and the battery, there should be an o-ring in there to keep the battery away from the firing button unless you push the button so check to make sure that's in place, and if not, you can find something at a hardware store that should work. I believe I ended up using a 2mm o-ring with a 13mm diameter, but I can't recall for sure so don't quote me on that Tongue

If it's not the o-ring, I don't know what the problem could be but I'm sure somebody here will help you out Smile
23-05-2016 04:09 AM
Visit this user's website Find all posts by this user Like Post Quote this message in a reply
gentlydoingit* Offline
TVF FreeCycle Manager
******
FreeCycle Manager

Posts: 6,195
Likes Given: 7,390
Likes Received: 9,653 in 4,266 posts
Joined: Nov 2015
Reputation: 192
Post: #3
RE: Mutant mech mod problems
I think the mutant has a switch like on the 4nine. I'm imagining when it's tightened up there's no switch throw and youve tried assembling the magnetic disk the other way round? I can't see a reason, perhaps the battery you have is a few mm longer than most others? You could try to take some off the 510+ threaded bit then take some thread off the adjuster screw.. i say that way because if the adjustable contact pin is too thin it could bend or warp giving a poor contact. Take as little a possible from it, but you could half the size of the 510+ flange it screws into.. be careful not to take too much out in total, the tolerances for magnetic floating switches aren't great. 
But deffo try another manufacturer battery first, they do vary in size.

Don't forget to apply for the freecycle section!
http://www.thevapingforum.com/Forum-FreeCycle--191
23-05-2016 09:50 AM
Find all posts by this user Like Post Quote this message in a reply
Post Reply