Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Aspire cf mod with an RDA?
Author Message
Spasmod Offline
Administrator
********
Administrators

Posts: 5,458
Likes Given: 8,023
Likes Received: 5,409 in 2,823 posts
Joined: Aug 2013
Reputation: 93
Post: #21
RE: Aspire cf mod with an RDA?
(21-02-2015 06:51 AM)Nihilum Wrote:  Personally, I wouldn't suggest putting an RDA on an Aspire CF.  Your clouds won't be any bigger and the flavor is not likely to be any better.  The sub-ohm battery was specifically designed to be paired with the Atlantis.  I'd suggest looking into the IPV Mini 2 or similar digital mod...or a tube mod.  They're moderately priced and are specifically designed to handle an RDA. 

This is simply the advice I'd give a customer in my shop who was looking to get into dripping, since moving to an RDA is more of a lateral move than a move up in the case of the Aspire CF

You do realise that the Aspire CF is just an 18650 cell (albeit with a charging circuit and a low ohm safety limit) right? 

Me personally, I would always recommend the CF in favour of a tube mod for someone just getting into using RDA's purely from a safety standpoint. 
21-02-2015 12:49 PM
Find all posts by this user Like Post Quote this message in a reply
[-] The following 1 user Likes Spasmod's post:
Eggza (08-08-2016)
Justjulian Offline
Junior Member
**

Posts: 1
Likes Given: 0
Likes Received: 0 in 0 posts
Joined: Aug 2016
Reputation: 0
Post: #22
RE: Aspire cf mod with an RDA?
I have a aspire cf mod with a freaks how rda but for some reason it keeps blinking as if it's short circuiting I tried atomizer tips to see if it was battery problems or mod itself but it's only when I put my rda on. I'm using 24g for the coil I tried dual coil with 5 wraps and single coil with 2-7 wraps and still blinking no fire with any coil I put on it. New to this build stuff so someone help.. When I have no coil but the tip on it glows as if it's good to fire (the blue led)
08-08-2016 04:11 PM
Find all posts by this user Like Post Quote this message in a reply
gentlydoingit* Offline
TVF FreeCycle Manager
******
FreeCycle Manager

Posts: 5,919
Likes Given: 6,888
Likes Received: 9,178 in 4,052 posts
Joined: Nov 2015
Reputation: 184
Post: #23
RE: Aspire cf mod with an RDA?
It's written as the minimum resistance for a coil on a cf sub is .3, though some are claiming .22.

Your dual coil (in kanthal) is a .2 so probably wont fire. Your single coil should work though.. however you may be getting a short across the coil if it's all bunched up. 
Try it with 8 2.5mm spaced wraps of your 24g but make sure none are touching, if it fires one coil you can go on to add another the same, that should bring you just above the .3 limit and still fire.
Other than that the 510 pin may be shorting, if your coil doesn't work we'll address that as a possible cause.

Don't forget to apply for the freecycle section!
http://www.thevapingforum.com/Forum-FreeCycle--191
08-08-2016 06:12 PM
Find all posts by this user Like Post Quote this message in a reply
[-] The following 3 users Like gentlydoingit*'s post:
bibliora (08-08-2016), ecignut (08-08-2016), Eggza (08-08-2016)
Post Reply